What’s Vulnerable › Vulnerabilities
CVE-2025-67730: Frappe authenticated users can execute XSS through form description fields
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-07
- Weakness: CWE-79
Description
Frappe Learning Management System (LMS) is a learning system that helps users structure their content. Versions prior to 2.42.0 allow authenticated users to add malicious HTML and JavaScript through description fields in the Job, Course and Batch forms. This issue is fixed in version 2.42.0.
Affected products
- frappe Learning: from 2.0.0 before 2.42.0 — fixed in 2.42.0
How to fix
Upgrade to a fixed version: frappe Learning 2.42.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/lms/commit/0877e32e1bfe64831b875707241de1c449cda45c
- https://github.com/frappe/lms/security/advisories/GHSA-jjc4-j3hw-33h2
Get alerted when CVE-2025-67730 or the next vulnerability affects your stack