What’s Vulnerable › Vulnerabilities
CVE-2025-67735: Netty has a CRLF Injection vulnerability in io.netty.handler.codec.http.HttpRequestEncoder
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-16 · updated 2026-10-14
- Weakness: CWE-93
Description
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.129.Final and 4.2.8.Final, the `io.netty.handler.codec.http.HttpRequestEncoder` has a CRLF injection with the request URI when constructing a request. This leads to request smuggling when `HttpRequestEncoder` is used without proper sanitization of the URI. Any application / framework using `HttpRequestEncoder` can be subject to be abused to perform request smuggling using CRLF injection. Versions 4.1.129.Final and 4.2.8.Final fix the issue.
Affected products
- netty: before 4.1.129; from 4.2.0 before 4.2.8 — fixed in 4.1.129, 4.2.8
How to fix
Upgrade to a fixed version: netty 4.1.129, 4.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-67735 or the next vulnerability affects your stack