What’s Vulnerable › Vulnerabilities
CVE-2025-67744: Mermaid XSS vulnerability leads to Remote Code Execution
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-16 · updated 2026-10-07
- Weakness: CWE-94
Description
DeepChat is an open-source artificial intelligence agent platform that unifies models, tools, and agents. Prior to version 0.5.3, a security vulnerability exists in the Mermaid diagram rendering component that allows arbitrary JavaScript execution. Due to the exposure of the Electron IPC renderer to the DOM, this Cross-Site Scripting (XSS) flaw escalates to full Remote Code Execution (RCE), allowing an attacker to execute arbitrary system commands. Two concurrent issues, unsafe Mermaid configuration and an exposed IPC interface, cause this issue. Version 0.5.3 contains a patch.
Affected products
- ThinkInAIXYZ deepchat: before 0.5.3 — fixed in 0.5.3
How to fix
Upgrade to a fixed version: ThinkInAIXYZ deepchat 0.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/ThinkInAIXYZ/deepchat/commit/b179d97921af04a0ae1ae68757338dd8b8cbefe7
- https://github.com/ThinkInAIXYZ/deepchat/security/advisories/GHSA-w8w8-82pv-5rg9
Get alerted when CVE-2025-67744 or the next vulnerability affects your stack