What’s Vulnerable › Vulnerabilities
CVE-2025-67746: Composer vulnerable to ANSI sequence injection
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-30 · updated 2026-06-17
- Weakness: CWE-74
Description
Composer is a dependency manager for PHP. In versions on the 2.x branch prior to 2.2.26 and 2.9.3, attackers controlling remote sources that Composer downloads from might in some way inject ANSI control characters in the terminal output of various Composer commands, causing mangled output and potentially leading to confusion or DoS of the terminal application. There is no proven exploit and this has thus a low severity but we still publish a CVE as it has potential for abuse, and we want to be on the safe side informing users that they should upgrade. Versions 2.2.26 and 2.9.3 contain a patch for the issue.
Affected products
- composer: from 2.0.0 before 2.2.26; from 2.3.0 before 2.9.3 — fixed in 2.2.26, 2.9.3
How to fix
Upgrade to a fixed version: composer 2.2.26, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/composer/composer/commit/1d40a95c9d39a6b7f80d404ab30336c586da9917
- https://github.com/composer/composer/commit/5db1876a76fdef76d3c4f8a27995c434c7a43e71
- https://github.com/composer/composer/releases/tag/2.2.26
- https://github.com/composer/composer/releases/tag/2.9.3
- https://github.com/composer/composer/security/advisories/GHSA-59pp-r3rg-353g
Get alerted when CVE-2025-67746 or the next vulnerability affects your stack