What’s Vulnerable › Vulnerabilities
CVE-2025-6775: xiaoyunjie openvpn-cms-flask User Creation Endpoint openvpn.py create_user command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-27 · updated 2026-06-17
- Weakness: CWE-74
Description
A vulnerability classified as critical has been found in xiaoyunjie openvpn-cms-flask up to 1.2.7. This affects the function create_user of the file /app/api/v1/openvpn.py of the component User Creation Endpoint. The manipulation of the argument Username leads to command injection. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.2.8 is able to address this issue. The patch is named e23559b98c8ea2957f09978c29f4e512ba789eb6. It is recommended to upgrade the affected component.
Affected products
- xiaoyunjie openvpn-cms-flask: before 1.2.8 — fixed in 1.2.8
How to fix
Upgrade to a fixed version: xiaoyunjie openvpn-cms-flask 1.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/xiaoyunjie/openvpn-cms-flask/commit/e23559b98c8ea2957f09978c29f4e512ba789eb6
- https://github.com/xiaoyunjie/openvpn-cms-flask/issues/24
- https://github.com/xiaoyunjie/openvpn-cms-flask/issues/24#issuecomment-2948563464
- https://github.com/xiaoyunjie/openvpn-cms-flask/releases/tag/v1.2.8
- https://vuldb.com/?ctiid.314091
- https://vuldb.com/?id.314091
- https://vuldb.com/?submit.602373
Get alerted when CVE-2025-6775 or the next vulnerability affects your stack