What’s Vulnerable › Vulnerabilities
CVE-2025-67752: OpenEMR Has Disabled SSL Certificate Verification in HTTP Client
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-25 · updated 2026-06-17
- Weakness: CWE-295
Description
OpenEMR is a free and open source electronic health records and medical practice management application. Prior to version 7.0.4, OpenEMR's HTTP client wrapper (`oeHttp`/`oeHttpRequest`) disables SSL/TLS certificate verification by default (`verify: false`), making all external HTTPS connections vulnerable to man-in-the-middle (MITM) attacks. This affects communication with government healthcare APIs and user-configurable external services, potentially exposing Protected Health Information (PHI). Version 7.0.4 fixes the issue.
Affected products
- openemr: before 7.0.4 — fixed in 7.0.4
How to fix
Upgrade to a fixed version: openemr 7.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/22f8e53e5769a88b7a16cb223bd197d044c84e5a
- https://github.com/openemr/openemr/security/advisories/GHSA-2g6h-725p-pqhp
Get alerted when CVE-2025-67752 or the next vulnerability affects your stack