What’s Vulnerable › Vulnerabilities
CVE-2025-67818
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-12 · updated 2026-10-14
- Weakness: CWE-22
Description
An issue was discovered in Weaviate OSS before 1.33.4. An attacker with access to insert data into the database can craft an entry name with an absolute path (e.g., /etc/...) or use parent directory traversal (../../..) to escape the restore root when a backup is restored, potentially creating or overwriting files in arbitrary locations within the application's privilege scope.
Affected products
- weaviate: before 1.33.4 — fixed in 1.33.4
How to fix
Upgrade to a fixed version: weaviate 1.33.4. Check the vendor advisory for mitigations.
References
- https://github.com/weaviate/weaviate
- https://weaviate.io/blog/weaviate-security-release-november-2025
Get alerted when CVE-2025-67818 or the next vulnerability affects your stack