What’s Vulnerable › Vulnerabilities
CVE-2025-67847: Moodle: moodle: remote code execution via insufficient restore input validation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-23 · updated 2026-06-17
- Weakness: CWE-94
Description
A flaw was found in Moodle. An attacker with access to the restore interface could trigger server-side execution of arbitrary code. This is due to insufficient validation of restore input, which leads to unintended interpretation by core restore routines. Successful exploitation could result in a full compromise of the Moodle application.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.12; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.12, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-67847 or the next vulnerability affects your stack