What’s Vulnerable › Vulnerabilities
CVE-2025-67848: Moodle: moodle: authentication bypass via lti provider allows suspended users to gain unauthorized access.
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-280
Description
A flaw was found in Moodle. This authentication bypass vulnerability allows suspended users to authenticate through the Learning Tools Interoperability (LTI) Provider. The issue arises from the LTI authentication handlers failing to enforce the user's suspension status, enabling unauthorized access to the system. This can lead to information disclosure or other unauthorized actions by users who should be restricted.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.11, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.11, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67848
- https://bugzilla.redhat.com/show_bug.cgi?id=2423831
- https://moodle.org/mod/forum/discuss.php?d=471298
Get alerted when CVE-2025-67848 or the next vulnerability affects your stack