What’s Vulnerable › Vulnerabilities
CVE-2025-67849: Moodle: moodle: cross-site scripting (xss) via improper sanitization of ai prompt responses
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A flaw was found in Moodle. This cross-site scripting (XSS) vulnerability, caused by improper sanitization of AI prompt responses, allows attackers to inject malicious HTML or script into web pages. When other users view these compromised pages, their sessions could be stolen, or the user interface could be manipulated.
Affected products
- Moodle: from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67849
- https://bugzilla.redhat.com/show_bug.cgi?id=2423835
Get alerted when CVE-2025-67849 or the next vulnerability affects your stack