What’s Vulnerable › Vulnerabilities
CVE-2025-67850: Moodle: moodle: cross-site scripting vulnerability via inadequate input filtering in formula editor
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A flaw was found in moodle. This vulnerability, known as Cross-Site Scripting (XSS), occurs due to insufficient checks on user-provided data in the formula editor's arithmetic expression fields. A remote attacker could inject malicious code into these fields. When other users view these expressions, the malicious code would execute in their web browsers, potentially compromising their data or leading to unauthorized actions.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.11, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.11, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67850
- https://bugzilla.redhat.com/show_bug.cgi?id=2423838
Get alerted when CVE-2025-67850 or the next vulnerability affects your stack