What’s Vulnerable › Vulnerabilities
CVE-2025-67851: Moodle: moodle: formula injection allows arbitrary formula execution via unescaped data export
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-1236
Description
A flaw was found in moodle. This formula injection vulnerability occurs when data fields are exported without proper escaping. A remote attacker could exploit this by providing malicious data that, when exported and opened in a spreadsheet, allows arbitrary formulas to execute. This can lead to compromised data integrity and unintended operations within the spreadsheet.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.11, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.11, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67851
- https://bugzilla.redhat.com/show_bug.cgi?id=2423841
- https://moodle.org/mod/forum/discuss.php?d=471301
Get alerted when CVE-2025-67851 or the next vulnerability affects your stack