What’s Vulnerable › Vulnerabilities
CVE-2025-67855: Mooodle: mooodle: information disclosure and script execution via reflected cross-site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A flaw was found in mooodle. A remote attacker could exploit a reflected Cross-Site Scripting (XSS) vulnerability in the policy tool return URL. This vulnerability arises from insufficient sanitization of URL parameters, allowing attackers to inject malicious scripts through specially crafted links. Successful exploitation could lead to information disclosure or arbitrary client-side script execution within the user's browser.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.11, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.11, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67855
- https://bugzilla.redhat.com/show_bug.cgi?id=2423861
Get alerted when CVE-2025-67855 or the next vulnerability affects your stack