What’s Vulnerable › Vulnerabilities
CVE-2025-67856: Moodle: moodle: privilege escalation via incomplete role checks in badge awarding
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-863
Description
A flaw was found in Moodle. An authorization logic flaw, specifically due to incomplete role checks during the badge awarding process, allowed badges to be granted without proper verification. This could enable unauthorized users to obtain badges they are not entitled to, potentially leading to privilege escalation or unauthorized access to certain features.
Affected products
- Moodle: before 4.1.22; from 4.4.0 before 4.4.12; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.22, 4.4.12, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.22, 4.4.12, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67856
- https://bugzilla.redhat.com/show_bug.cgi?id=2423864
Get alerted when CVE-2025-67856 or the next vulnerability affects your stack