What’s Vulnerable › Vulnerabilities
CVE-2025-67857: Moodle: moodle: data exposure of user identifiers in urls
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-03 · updated 2026-06-17
- Weakness: CWE-201
Description
A flaw was found in moodle. During anonymous assignment submissions, user identifiers were inadvertently exposed in URLs. This data exposure allows unauthorized viewers to see internal user IDs, compromising the intended anonymity and potentially leading to information disclosure.
Affected products
- Moodle: before 4.1.21; from 4.4.0 before 4.4.11; from 4.5.0 before 4.5.8; from 5.0.0 before 5.0.4; 5.1.0 — fixed in 4.1.21, 4.4.11, 4.5.8, 5.0.4
How to fix
Upgrade to a fixed version: Moodle 4.1.21, 4.4.11, 4.5.8, 5.0.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2025-67857
- https://bugzilla.redhat.com/show_bug.cgi?id=2423868
- https://moodle.org/mod/forum/discuss.php?d=471307
Get alerted when CVE-2025-67857 or the next vulnerability affects your stack