What’s Vulnerable › Vulnerabilities
CVE-2025-67896
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-14 · updated 2026-10-14
- Weakness: CWE-122
Description
Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.
Affected products
- Exim: before 4.99.1 — fixed in 4.99.1
How to fix
Upgrade to a fixed version: Exim 4.99.1. Check the vendor advisory for mitigations.
References
- https://exim.org/static/doc/security/
- https://exim.org/static/doc/security/EXIM-Security-2025-12-09.1/report.txt
- https://www.openwall.com/lists/oss-security/2025/12/11/2
- http://www.openwall.com/lists/oss-security/2025/12/14/1
- http://www.openwall.com/lists/oss-security/2025/12/18/3
Get alerted when CVE-2025-67896 or the next vulnerability affects your stack