What’s Vulnerable › Vulnerabilities
CVE-2025-67897
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-14 · updated 2026-10-14
- Weakness: CWE-195
Description
In Sequoia before 2.1.0, aes_key_unwrap panics if passed a ciphertext that is too short. A remote attacker can take advantage of this issue to crash an application by sending a victim an encrypted message with a crafted PKESK or SKESK packet.
Affected products
- sequoia-pgp sequoia: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: sequoia-pgp sequoia 2.1.0. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/1122582
- https://gitlab.com/sequoia-pgp/sequoia/-/blob/b59886e5e7bdf7169ed330f309a6633d131776e5/openpgp/NEWS#L7-L26
- https://gitlab.com/sequoia-pgp/sequoia/-/commit/b59886e5e7bdf7169ed330f309a6633d131776e5
Get alerted when CVE-2025-67897 or the next vulnerability affects your stack