What’s Vulnerable › Vulnerabilities
CVE-2025-6790: QSM < 10.2.3 - Template Creation via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-14 · updated 2026-06-17
Description
The Quiz and Survey Master (QSM) WordPress plugin before 10.2.3 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack.
Affected products
- ExpressTech Quiz And Survey Master: before 10.2.3 — fixed in 10.2.3
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 10.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/af337f9f-c955-49eb-9675-2f85da96fcfe/
- https://wpscan.com/vulnerability/af337f9f-c955-49eb-9675-2f85da96fcfe/
Get alerted when CVE-2025-6790 or the next vulnerability affects your stack