What’s Vulnerable › Vulnerabilities
CVE-2025-68115: Parse Server vulnerable to Cross-Site Scripting (XSS) via Unescaped Mustache Template Variables
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-16 · updated 2026-10-07
- Weakness: CWE-79
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 8.6.1 and 9.1.0-alpha.3, a Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server's password reset and email verification HTML pages. The patch, available in versions 8.6.1 and 9.1.0-alpha.3, escapes user controlled values that are inserted into the HTML pages. No known workarounds are available.
Affected products
- parse-community parse-server: before 8.6.1; 9.0.0, 9.0.0-alpha1, 9.0.0-alpha10, 9.0.0-alpha11, 9.0.0-alpha2, 9.0.0-alpha3 (+8) — fixed in 8.6.1
How to fix
Upgrade to a fixed version: parse-community parse-server 8.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/pull/9985
- https://github.com/parse-community/parse-server/pull/9986
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv
Get alerted when CVE-2025-68115 or the next vulnerability affects your stack