What’s Vulnerable › Vulnerabilities
CVE-2025-68116: FileRise vulnerable to Cross-Site Scripting (XSS) in SVG File Handling
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-16 · updated 2026-06-17
- Weakness: CWE-79
Description
FileRise is a self-hosted web file manager / WebDAV server. Versions prior to 2.7.1 are vulnerable to Stored Cross-Site Scripting (XSS) due to unsafe handling of browser-renderable user uploads when served through the sharing and download endpoints. An attacker who can get a crafted SVG (primary) or HTML (secondary) file stored in a FileRise instance can cause JavaScript execution when a victim opens a generated share link (and in some cases via the direct download endpoint). This impacts share links (`/api/file/share.php`) and direct file access / download path (`/api/file/download.php`), depending on browser/content-type behavior. Version 2.7.1 fixes the issue.
Affected products
- error311 FileRise: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: error311 FileRise 2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68116 or the next vulnerability affects your stack