What’s Vulnerable › Vulnerabilities
CVE-2025-68134: EVerest's use of assert functions can potentially lead to denial of service
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-21 · updated 2026-06-17
- Weakness: CWE-20
Description
EVerest is an EV charging software stack. Prior to version 2025.10.0, the use of the `assert` function to handle errors frequently causes the module to crash. This is particularly critical because the manager shuts down all other modules and exits when any one of them terminates, leading to a denial of service. In a context where a manager handles multiple EVSE, this would also impact other users. Version 2025.10.0 fixes the issue.
Affected products
- everest-core: before 2025.10.0 — fixed in 2025.10.0
How to fix
Upgrade to a fixed version: everest-core 2025.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68134 or the next vulnerability affects your stack