What’s Vulnerable › Vulnerabilities
CVE-2025-68381: Packetbeat Improper Bounds Check
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-06-17
- Weakness: CWE-787
Description
Improper Bounds Check (CWE-787) in Packetbeat can allow a remote unauthenticated attacker to exploit a Buffer Overflow (CAPEC-100) and reliably crash the application or cause significant resource exhaustion via a single crafted UDP packet with an invalid fragment sequence number.
Affected products
- Elastic Packetbeat: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.9; from 9.0.0 before 9.1.9; from 9.2.0 before 9.2.3 — fixed in 8.19.9, 9.1.9, 9.2.3
How to fix
Upgrade to a fixed version: Elastic Packetbeat 8.19.9, 9.1.9, 9.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68381 or the next vulnerability affects your stack