What’s Vulnerable › Vulnerabilities
CVE-2025-68383: Filebeat Improper Validation of Specified Index, Position, or Offset in Input
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-06-17
- Weakness: CWE-1284
Description
Improper Validation of Specified Index, Position, or Offset in Input (CWE-1285) in Filebeat Syslog parser and the Libbeat Dissect processor can allow a user to trigger a Buffer Overflow (CAPEC-100) and cause a denial of service (panic/crash) of the Filebeat process via either a malformed Syslog message or a malicious tokenizer pattern in the Dissect configuration.
Affected products
- Elastic Filebeat: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.9; from 9.0.0 before 9.1.9; from 9.2.0 before 9.2.3 — fixed in 8.19.9, 9.1.9, 9.2.3
How to fix
Upgrade to a fixed version: Elastic Filebeat 8.19.9, 9.1.9, 9.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68383 or the next vulnerability affects your stack