What’s Vulnerable › Vulnerabilities
CVE-2025-68387: Kibana Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper neutralization of input during web page generation ('Cross-site Scripting') (CWE-79) allows an unauthenticated user to embed a malicious script in content that will be served to web browsers causing cross-site scripting (XSS) (CAPEC-63) via a vulnerability a function handler in the Vega AST evaluator.
Affected products
- Kibana: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.9; from 9.0.0 before 9.1.9; from 9.2.0 before 9.2.3 — fixed in 8.19.9, 9.1.9, 9.2.3
How to fix
Upgrade to a fixed version: Kibana 8.19.9, 9.1.9, 9.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68387 or the next vulnerability affects your stack