What’s Vulnerable › Vulnerabilities
CVE-2025-68398: Weblate has git config file overwrite vulnerability that leads to remote code execution
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-09-30
- Weakness: CWE-20
Description
Weblate is a web based localization tool. In versions prior to 5.15.1, it was possible to overwrite Git configuration remotely and override some of its behavior. Version 5.15.1 fixes the issue.
Affected products
- WeblateOrg weblate: before 5.15.1 — fixed in 5.15.1
How to fix
Upgrade to a fixed version: WeblateOrg weblate 5.15.1. Check the vendor advisory for mitigations.
References
- https://github.com/WeblateOrg/weblate/commit/4837a4154390f7c1d03c0e398aa6439dcfa361b4
- https://github.com/WeblateOrg/weblate/commit/dd8c9d7b00eebe28770fa0e2cd96126791765ea7
- https://github.com/WeblateOrg/weblate/pull/17330
- https://github.com/WeblateOrg/weblate/pull/17345
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-5.15.1
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-8vcg-cfxj-p5m3
Get alerted when CVE-2025-68398 or the next vulnerability affects your stack