What’s Vulnerable › Vulnerabilities
CVE-2025-68399: ChurchCRM has Stored Cross-Site Scripting (XSS) In GroupEditor.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-17 · updated 2026-06-17
- Weakness: CWE-79
Description
ChurchCRM is an open-source church management system. In versions prior to 6.5.4, there is a Stored Cross-Site Scripting (XSS) vulnerability within the GroupEditor.php page of the application. When a user attempts to create a group role, they can execute malicious JavaScript. However, for this to work, the user must have permission to view and modify groups in the application. Version 6.5.4 fixes the issue.
Affected products
- ChurchCRM CRM: before 6.5.4 — fixed in 6.5.4
How to fix
Upgrade to a fixed version: ChurchCRM CRM 6.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-gfxf-w4cg-c54j
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-gfxf-w4cg-c54j
Get alerted when CVE-2025-68399 or the next vulnerability affects your stack