What’s Vulnerable › Vulnerabilities
CVE-2025-68401: ChurchCRM has Stored Cross-Site Scripting (XSS) vulnerability that leads to session theft and account takeover
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-17 · updated 2026-06-17
- Weakness: CWE-79
Description
ChurchCRM is an open-source church management system. Prior to version 6.0.0, the application stores user-supplied HTML/JS without sufficient sanitization/encoding. When other users later view this content, attacker-controlled JavaScript executes in their browser (stored XSS). In affected contexts the script can access web origin data and perform privileged actions as the victim. Where session cookies are not marked HttpOnly, the script can read document.cookie, enabling session theft and account takeover. Version 6.0.0 patches the issue.
Affected products
- ChurchCRM CRM: before 6.0.0 — fixed in 6.0.0
How to fix
Upgrade to a fixed version: ChurchCRM CRM 6.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-phfw-p278-qq7v
- https://github.com/ChurchCRM/CRM/security/advisories/GHSA-phfw-p278-qq7v
Get alerted when CVE-2025-68401 or the next vulnerability affects your stack