What’s Vulnerable › Vulnerabilities
CVE-2025-68404: vcs_pentest Race Condition Authentication Bypass Vulnerability in QuRouter management interface
- Severity: high (CVSS 7.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-15 · updated 2026-10-19
- Weakness: CWE-367
Description
A time-of-check time-of-use (toctou) race condition vulnerability has been reported to affect QuRouter. If exploited, the vulnerability could allow remote attackers to compromise the security of the system. We have already fixed the vulnerability in the following version: QuRouter 2.6.4.001 and later
Affected products
- QNAP Systems Inc. QuRouter: from 2.6.x before 2.6.4.001 — fixed in 2.6.4.001
How to fix
Upgrade to a fixed version: QNAP Systems Inc. QuRouter 2.6.4.001. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68404 or the next vulnerability affects your stack