What’s Vulnerable › Vulnerabilities
CVE-2025-68420: Privilege Escalation in Comarch ERP Optima
- Severity: high (CVSS 7.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-10-07
- Weakness: CWE-266
Description
Comarch ERP Optima client connects to a database using a high privileged account regardless of an application account to which a user logs in. It is possible for a local attacker who controls the client process to dump it's memory, extract credentials and use them to gain a privileged access to the database. In order to exploit this vulnerability, the client application has to be already configured, but a user does not have to be logged in. This issue has been fixed in version 2026.4
Affected products
- Comarch ERP Optima: before 2026.4 — fixed in 2026.4
How to fix
Upgrade to a fixed version: Comarch ERP Optima 2026.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68420 or the next vulnerability affects your stack