What’s Vulnerable › Vulnerabilities
CVE-2025-68422: Kibana Improper Authorization
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-18 · updated 2026-06-17
- Weakness: CWE-863
Description
Improper Authorization (CWE-285) in Kibana can lead to privilege escalation (CAPEC-233) by allowing an authenticated user to bypass intended permission restrictions via a crafted HTTP request. This allows an attacker who lacks the live queries - read permission to successfully retrieve the list of live queries.
Affected products
- Kibana: from 7.0.0 through 7.17.29; from 8.0.0 before 8.19.7; from 9.0.0 before 9.1.7; 9.2.0 — fixed in 8.19.7, 9.1.7
How to fix
Upgrade to a fixed version: Kibana 8.19.7, 9.1.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68422 or the next vulnerability affects your stack