What’s Vulnerable › Vulnerabilities

CVE-2025-68436: Craft CMS vulnerable to potential information disclosure via unchecked asset relocation

Description

Craft is a platform for creating digital experiences. In versions 5.0.0-RC1 through 5.8.20 and 4.0.0-RC1 through 4.16.16, authenticated users on a Craft installation could potentially expose sensitive assets via their user profile photo via maliciously crafted requests. Users should update to the patched versions (5.8.21 and 4.16.17) to mitigate the issue.

Affected products

How to fix

Upgrade to a fixed version: craftcms cms 4.16.17, 5.8.21. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-68436 or the next vulnerability affects your stack