What’s Vulnerable › Vulnerabilities
CVE-2025-68438: Apache Airflow: Secrets in rendered templates could contain parts of sensitive values when truncated
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-200
Description
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. This occurred because serialization of those fields used a secrets masker instance that did not include user-registered mask_secret() patterns, so secrets were not reliably masked before truncation and display. Users are recommended to upgrade to 3.1.6 or later, which fixes this issue
Affected products
- Apache Airflow: from 3.1.0 before 3.1.6 — fixed in 3.1.6
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/55n7b4nlsz3vo5n4h5lrj9bfsk8ctyff
- http://www.openwall.com/lists/oss-security/2026/01/15/5
Get alerted when CVE-2025-68438 or the next vulnerability affects your stack