What’s Vulnerable › Vulnerabilities
CVE-2025-68469: ImageMagick vulnerable to heap-buffer-overflow
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-18 · updated 2026-10-13
- Weakness: CWE-122
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.1-14, ImageMagick crashes when processing a crafted TIFF file. Version 7.1.1-14 fixes the issue.
Affected products
- ImageMagick: before 7.1.1-14 — fixed in 7.1.1-14
How to fix
Upgrade to a fixed version: ImageMagick 7.1.1-14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68469 or the next vulnerability affects your stack