What’s Vulnerable › Vulnerabilities
CVE-2025-68477: Langflow vulnerable to Server-Side Request Forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-19 · updated 2026-10-13
- Weakness: CWE-918
Description
Langflow is a tool for building and deploying AI-powered agents and workflows. Prior to version 1.7.0, Langflow provides an API Request component that can issue arbitrary HTTP requests within a flow. This component takes a user-supplied URL, performs only normalization and basic format checks, and then sends the request using a server-side httpx client. It does not block private IP ranges (127[.]0[.]0[.]1, the 10/172/192 ranges) or cloud metadata endpoints (169[.]254[.]169[.]254), and it returns the response body as the result. Because the flow execution endpoints (/api/v1/run, /api/v1/run/advanced) can be invoked with just an API key, if an attacker can control the API Request URL in a flow, non-blind SSRF is possible—accessing internal resources from the server’s network context. This enables requests to, and collection of responses from, internal administrative endpoints, metadata services, and internal databases/services, leading to information disclosure and providing a foothold for further attacks. Version 1.7.0 contains a patch for this issue.
Affected products
- IBM Langflow OSS: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: IBM Langflow OSS 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-5993-7p27-66g5
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-5993-7p27-66g5
Get alerted when CVE-2025-68477 or the next vulnerability affects your stack