What’s Vulnerable › Vulnerabilities

CVE-2025-68493: Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component

Description

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 6.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-68493 or the next vulnerability affects your stack