What’s Vulnerable › Vulnerabilities
CVE-2025-6851: Broken Link Notifier <= 1.3.0 - Unauthenticated Server-Side Request Forgery
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-918
Description
The Broken Link Notifier plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.3.0 via the ajax_blinks() function which ultimately calls the check_url_status_code() function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Affected products
- apos37 Broken Link Notifier: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: apos37 Broken Link Notifier 1.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3323864%40broken-link-notifier&new=3323864%40broken-link-notifier&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0f76c9f8-c57a-4875-b581-f67c9c60021c?source=cve
Get alerted when CVE-2025-6851 or the next vulnerability affects your stack