What’s Vulnerable › Vulnerabilities
CVE-2025-68614: LibreNMS Alert Rule API Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-23 · updated 2026-10-19
- Weakness: CWE-79
Description
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Prior to version 25.12.0, the Alert Rule API is vulnerable to stored cross-site scripting. Alert rules can be created or updated via LibreNMS API. The alert rule name is not properly sanitized, and can be used to inject HTML code. This issue has been patched in version 25.12.0.
Affected products
- librenms: before 25.12.0 — fixed in 25.12.0
How to fix
Upgrade to a fixed version: librenms 25.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/ebe6c79bf4ce0afeb575c1285afe3934e44001f1
- https://github.com/librenms/librenms/security/advisories/GHSA-c89f-8g7g-59wj
Get alerted when CVE-2025-68614 or the next vulnerability affects your stack