What’s Vulnerable › Vulnerabilities
CVE-2025-68615: Net-SNMP snmptrapd crash
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 42.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-23 · updated 2026-10-19
- Weakness: CWE-119
Description
net-snmp is a SNMP application library, tools and daemon. Prior to versions 5.9.5 and 5.10.pre2, a specially crafted packet to an net-snmp snmptrapd daemon can cause a buffer overflow and the daemon to crash. This issue has been patched in versions 5.9.5 and 5.10.pre2.
Affected products
- Debian Linux: 11.0
- net-snmp: before 5.9.5; 5.10-pre1 — fixed in 5.9.5
How to fix
Upgrade to a fixed version: net-snmp 5.9.5. Check the vendor advisory for mitigations.
References
- https://github.com/net-snmp/net-snmp/security/advisories/GHSA-4389-rwqf-q9gq
- http://www.openwall.com/lists/oss-security/2026/01/09/2
- https://lists.debian.org/debian-lts-announce/2026/01/msg00000.html
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-detection-script-buffer-overflow-vulnerability-affecting-net-snmp
- https://www.vicarius.io/vsociety/posts/cve-2025-68615-mitigation-script-buffer-overflow-vulnerability-affecting-net-snmp
Get alerted when CVE-2025-68615 or the next vulnerability affects your stack