What’s Vulnerable › Vulnerabilities
CVE-2025-68618: Magick's failure to limit the depth of SVG file reads caused a DoS attack.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-30 · updated 2026-06-17
- Weakness: CWE-674
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to version 7.1.2-12, using Magick to read a malicious SVG file resulted in a DoS attack. Version 7.1.2-12 fixes the issue.
Affected products
- ImageMagick: before 7.1.2-12 — fixed in 7.1.2-12
How to fix
Upgrade to a fixed version: ImageMagick 7.1.2-12. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/6f431d445f3ddd609c004a1dde617b0a73e60beb
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-p27m-hp98-6637
Get alerted when CVE-2025-68618 or the next vulnerability affects your stack