What’s Vulnerable › Vulnerabilities
CVE-2025-68619: Signal K Server Vulnerable to Remote Code Execution via Malicious npm Package
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-01 · updated 2026-10-07
- Weakness: CWE-94
Description
Signal K Server is a server application that runs on a central hub in a boat. Versions prior to 2.19.0 of the appstore interface allow administrators to install npm packages through a REST API endpoint. While the endpoint validates that the package name exists in the npm registry as a known plugin or webapp, the version parameter accepts arbitrary npm version specifiers including URLs. npm supports installing packages from git repositories, GitHub shorthand syntax, and HTTP/HTTPS URLs pointing to tarballs. When npm installs a package, it can automatically execute any `postinstall` script defined in `package.json`, enabling arbitrary code execution. The vulnerability exists because npm's version specifier syntax is extremely flexible, and the SignalK code passes the version parameter directly to npm without sanitization. An attacker with admin access can install a package from an attacker-controlled source containing a malicious `postinstall` script. Version 2.19.0 contains a patch for the issue.
Affected products
- signalk-server: before 2.19.0; 2.19.0-beta1, 2.19.0-beta2, 2.19.0-beta3, 2.19.0-beta4 — fixed in 2.19.0
How to fix
Upgrade to a fixed version: signalk-server 2.19.0. Check the vendor advisory for mitigations.
References
- https://github.com/SignalK/signalk-server/releases/tag/v2.19.0
- https://github.com/SignalK/signalk-server/security/advisories/GHSA-93jc-vqqc-vvvh
Get alerted when CVE-2025-68619 or the next vulnerability affects your stack