What’s Vulnerable › Vulnerabilities
CVE-2025-68637: Apache Uniffle: Insecure SSL Configuration in Uniffle HTTP Client
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-07 · updated 2026-10-07
- Weakness: CWE-297
Description
The Uniffle HTTP client is configured to trust all SSL certificates and disables hostname verification by default. This insecure configuration exposes all REST API communication between the Uniffle CLI/client and the Uniffle Coordinator service to potential Man-in-the-Middle (MITM) attacks. This issue affects all versions from before 0.10.0. Users are recommended to upgrade to version 0.10.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Uniffle: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Uniffle 0.10.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/trvdd11hmpbjno3t8rc9okr4t036ox2v
- http://www.openwall.com/lists/oss-security/2025/12/27/2
Get alerted when CVE-2025-68637 or the next vulnerability affects your stack