What’s Vulnerable › Vulnerabilities
CVE-2025-68658: Open Source Point of Sale (opensourcepos) Stored XSS in Configuration (Information) – Company Name field
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Open Source Point of Sale (opensourcepos) is a web based point of sale application written in PHP using CodeIgniter framework. opensourcepos 3.4.0 and 3.4.1 has a stored XSS vulnerability exists in the Configuration (Information) functionality. An authenticated user with the permission “Configuration: Change OSPOS's Configuration” can inject a malicious JavaScript payload into the Company Name field when updating Information in Configuration. The malicious payload is stored and later triggered when a user accesses /sales/complete. First select Sales, and choose New Item to create an item, then click on Completed . Due to insufficient input validation and output encoding, the payload is rendered and executed in the user’s browser, resulting in a stored XSS vulnerability. This vulnerability is fixed in 3.4.2.
Affected products
- opensourcepos Open Source Point of Sale: from 3.4.0 before 3.4.2 — fixed in 3.4.2
How to fix
Upgrade to a fixed version: opensourcepos Open Source Point of Sale 3.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/opensourcepos/opensourcepos/commit/849439c71eaa4c15857fb7c603297261c2ddc26d
- https://github.com/opensourcepos/opensourcepos/security/advisories/GHSA-32r8-8r9r-9chw
Get alerted when CVE-2025-68658 or the next vulnerability affects your stack