What’s Vulnerable › Vulnerabilities
CVE-2025-68660: Discourse AI Discover's continue conversation allows threat actor to impersonate user
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-863
Description
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, an endpoint lets any authenticated user bypass the ai_discover_persona access controls and gain ongoing DM access to personas that may be wired to staff-only categories, RAG document sets, or automated tooling, enabling unauthorized data disclosure. Because the controller also accepts arbitrary user_id, an attacker can impersonate other accounts to trigger unwanted AI conversations on their behalf, generating confusing or abusive PM traffic. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. No known workarounds are available.
Affected products
- discourse: before 3.5.4; from 2025.11.0 before 2025.11.2; 2025.12.0, 2026.1.0 — fixed in 2025.11.2, 3.5.4
How to fix
Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68660 or the next vulnerability affects your stack