What’s Vulnerable › Vulnerabilities
CVE-2025-68669: 5ire vulnerable to Remote Code Execution (RCE) via mermaid
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-23 · updated 2026-10-19
- Weakness: CWE-79
Description
5ire is a cross-platform desktop artificial intelligence assistant and model context protocol client. In versions 0.15.2 and prior, an RCE vulnerability exists in useMarkdown.ts, where the markdown-it-mermaid plugin is initialized with securityLevel: 'loose'. This configuration explicitly permits the rendering of HTML tags within Mermaid diagram nodes. This issue has not been patched at time of publication.
Affected products
- nanbingxyz 5ire: before 0.15.2 — fixed in 0.15.2
How to fix
Upgrade to a fixed version: nanbingxyz 5ire 0.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/nanbingxyz/5ire/blob/c40d05a2b546094789fc727daa5383bb15034442/src/hooks/useMarkdown.ts#L156
- https://github.com/nanbingxyz/5ire/commit/1fbe40d0bfbfe215370d45b9af856c286d67d3f2
- https://github.com/nanbingxyz/5ire/releases/tag/v0.15.2
- https://github.com/nanbingxyz/5ire/security/advisories/GHSA-5hpf-p8fw-j349
- https://github.com/nanbingxyz/5ire/security/advisories/GHSA-5hpf-p8fw-j349
Get alerted when CVE-2025-68669 or the next vulnerability affects your stack