What’s Vulnerable › Vulnerabilities
CVE-2025-68670: xrdp improperly checks bounds of domain string length, which leads to Stack-based Buffer Overflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-27 · updated 2026-06-17
- Weakness: CWE-121
Description
xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.
Affected products
- Debian Linux: 11.0
- neutrinolabs xrdp: before 0.10.5 — fixed in 0.10.5
How to fix
Upgrade to a fixed version: neutrinolabs xrdp 0.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/neutrinolabs/xrdp/commit/488c8c7d4d189514a366cd8301b6e816c5218ffa
- https://github.com/neutrinolabs/xrdp/releases/tag/v0.10.5
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-rwvg-gp87-gh6f
- https://lists.debian.org/debian-lts-announce/2026/02/msg00003.html
Get alerted when CVE-2025-68670 or the next vulnerability affects your stack