What’s Vulnerable › Vulnerabilities
CVE-2025-68675: Apache Airflow: proxy credentials for various providers might leak in task logs
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-16 · updated 2026-06-17
- Weakness: CWE-532
Description
In Apache Airflow versions before 3.1.6, and 2.11.1 the proxies and proxy fields within a Connection may include proxy URLs containing embedded authentication information. These fields were not treated as sensitive by default and therefore were not automatically masked in log output. As a result, when such connections are rendered or printed to logs, proxy credentials embedded in these fields could be exposed. Users are recommended to upgrade to 3.1.6 or later for Airflow 3, and 2.11.1 or later for Airflow 2 which fixes this issue
Affected products
- Apache Airflow: before 3.1.6 — fixed in 3.1.6
How to fix
Upgrade to a fixed version: Apache Airflow 3.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/59688
- https://lists.apache.org/thread/x6kply4nqd4vc4wgxtm6g9r2tt63s8c5
- http://www.openwall.com/lists/oss-security/2026/01/15/6
Get alerted when CVE-2025-68675 or the next vulnerability affects your stack