What’s Vulnerable › Vulnerabilities
CVE-2025-68933: Discourse non-admin moderators can exfiltrate private content via post ownership transfer
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-28 · updated 2026-06-17
- Weakness: CWE-863
Description
Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, non-admin moderators with the `moderators_change_post_ownership` setting enabled can change ownership of posts in private messages and restricted categories they cannot access, then export their data to view the content. This is a broken access control vulnerability affecting sites that grant moderators post ownership transfer permissions. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. The patch adds visibility checks for both the topic and posts before allowing ownership transfer. As a workaround, disable the `moderators_change_post_ownership` site setting to prevent non-admin moderators from using the post ownership transfer feature.
Affected products
- discourse: before 3.5.4; from 2025.11.0 before 2025.11.2; 2025.12.0, 2026.1.0 — fixed in 2025.11.2, 3.5.4
How to fix
Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-68933 or the next vulnerability affects your stack