What’s Vulnerable › Vulnerabilities

CVE-2025-68934: Discourse Has Denial of Service (DoS) Vulnerability in Drafts Creation Endpoint

Description

Discourse is an open source discussion platform. In versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0, authenticated users can submit crafted payloads to /drafts.json that cause O(n^2) processing in Base62.decode, tying up workers for 35-60 seconds per request. This affects all users as the shared worker pool becomes exhausted. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. Lowering the max_draft_length site setting reduces attack surface but does not fully mitigate the issue, as payloads under the limit can still trigger the slow code path.

Affected products

How to fix

Upgrade to a fixed version: discourse 2025.11.2, 3.5.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-68934 or the next vulnerability affects your stack