What’s Vulnerable › Vulnerabilities
CVE-2025-68940
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-26 · updated 2026-10-13
- Weakness: CWE-863
Description
In Gitea before 1.22.5, branch deletion permissions are not adequately enforced after merging a pull request.
Affected products
- Gitea Open Source Git Server: before 1.22.5 — fixed in 1.22.5
How to fix
Upgrade to a fixed version: Gitea Open Source Git Server 1.22.5. Check the vendor advisory for mitigations.
References
- https://blog.gitea.com/release-of-1.22.5/
- https://github.com/go-gitea/gitea/pull/32654
- https://github.com/go-gitea/gitea/releases/tag/v1.22.5
Get alerted when CVE-2025-68940 or the next vulnerability affects your stack