What’s Vulnerable › Vulnerabilities
CVE-2025-68951: phpMyFAQ has stored XSS in admin "List of users" via display_name HTML entity decoding (html_entity_decode) + Twig |raw
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-29 · updated 2026-10-07
- Weakness: CWE-79
Description
phpMyFAQ is an open source FAQ web application. Versions 4.0.14 and 4.0.15 have a stored cross-site scripting (XSS) vulnerability that allows an attacker to execute arbitrary JavaScript in an administrator’s browser by registering a user whose display name contains HTML entities. When an administrator views the admin user list, the payload is decoded server-side and rendered without escaping, resulting in script execution in the admin context. Version 4.0.16 contains a patch for the issue.
Affected products
- thorsten phpMyFAQ: from 4.0.14 before 4.0.16; 4.1.0-rc — fixed in 4.0.16
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.0.16. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/commit/61829e83411f7b28bc6fd1052bfde54c32c6c370
- https://github.com/thorsten/phpMyFAQ/commit/8211d1d25951b4c272443cfc3ef9c09b1363fd87
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-jv8r-hv7q-p6vc
Get alerted when CVE-2025-68951 or the next vulnerability affects your stack